Android Run 시 아래와 같은 에러가 났을 경우


[2016-02-15 11:25:55 - Dex Loader] Unable to execute dex: Multiple dex files define

[2016-02-15 11:25:55 - Test] Conversion to Dalvik format failed: Unable to execute dex: Multiple dex files define


android-support-v7-appcompat 프로젝트가 Library 에 추가 되었는지 확인해본다.


해당 프로젝트 우클릭 - Properties - Android 탭 하단에서 볼 수 있다.


Library 를 보면 android-support-v7-appcompat 프로젝트가 추가 되었는지 볼 수 있는데 필자의 경우 android-support-v7-appcompat 라이브러리가 사라져 있었다.






이런 경우 android-support-v7-appcompat 라이브러리 프로젝트를 따로 import 시켜주어야 한다. 



이 프로젝트는 아마 처음 Android Project를 새로 생성할 때 OS 4.4.4 킷캣 이상 버전으로 생성하면 자동으로 생성되었던 라이브러리이다.

(android-support-v7-appcompat 이게 생성 안되게 프로젝트를 생성하는 방법이 있다곤 하는데 우선 급한 불 부터 꺼보겠다)


그런데 이게 가끔 지멋대로 프로젝트가 사라진다거나 이상하게 깨지는 경우가 많다. 

그래서 이게 생성안되게 새 프로젝트 생성시 4.1.2로 만들곤 한다.


혹시 몰라 첨부..


android-support-v7-appcompat.zip



android-support-v7-appcompat를 import 하였다면 이제 작업하는 프로젝트에 추가해주어야 한다.


Add 버튼을 누르면 라이브러리 프로젝트 선택화면이 나온다.




android-support-v7-appcompat를 선택하고 ok를 누르면







초록색으로 체크표시가 되고 추가가 될 것이다. Apply를 눌러 적용시키고


이제 다시 한번 프로젝트를 Run 해본다.


그래도 안된다면 다음 링크를 참고해본다.


http://stackoverflow.com/questions/7870265/unable-to-execute-dex-multiple-dex-files-define-lcom-myapp-rarray


http://www.androidside.com/bbs/board.php?bo_table=B56&wr_id=27196



+ Recent posts